1С: Самвестимо СЗВ-ТД

А что там с этим СЗВ-ТД, кто в курсе?
Наверное, пора начинать делать, но не могу понять, а есть ли какие-то официальные документы по формату?
Пусть даже не зарегистрированные в минюсте?
А то везде один треп пустой.
Редактировано: 30 января 2020

Комментарии:
Страница 2 из 2
< 1 2
И ты правильно делаешь, что как истинный одинесник с большой буквы раз один 1, не читаешь мануалов и не смотришь видосов.
Ну зачем дерзить то сразу. Я смотрел видос. Вручную выискивать состояние на 1.1.2020 по каждому сотруднику это совсем не комильфо. А если их больше сотни? Всё равно до 15.02.2021 работодатели должны сдать эти сведения о всех работниках. И ещё сдавать сведения о заявлениях тоже на всех. При этом ещё вспоминать, на кого сдавали, а на кого нет... Кроме того надо ещё где-то хранить UUID, ведь его нужно указывать в случае отмены неверных сведений...
Ну зачем дерзить то сразу.
А чего тянуть кота за хвост?
Ты же собираешься меня учить огурцы в банках солить. У тебя же для этого тещи-то нету ...
А если у тебя за январь 2020 года больше сотни кадровых мероприятий, то иди к Миллеру и поучи его щи варить. Он же тебе и вспомнит на кого ты отчет сдавал в прошлом году с неверными сведениями.
А если у тебя за январь 2020 года больше сотни кадровых мероприятий, то иди к
Ты не понял. Текущие кадровые мероприятия - это малая толика из того, что предстоит сдавать работодателю в СЗВ-ТД. Кроме них ему предстоит в этом году сдать сведения на Всех работников по состоянию на 1.1.2020, и на Всех работников сдать сведения о заявлениях (которые у вас не реализованы вообще).
Кирилл1, слезь с руля
Иди в свой Газпром и там втирай своему Миллеру про пользу Арбидола ...
ТекРелиз="2019.04";

Теперь можно печатать заявления и уведомление на ЭТК и БТК из обработки.
Добавлена поддержка 1С:Предприниматель.
Добавлена система ФастХелп.
Ну, и так, кой-чего по мелочи ...
Чтобы Заявления печатались по-русски, в комплекте есть компонента, которая склоняет слова по падежам - чтобы в шапке заявления было
"Генеральному Директору Иванову Ивану Ивановичу сотрудника Петрова Петра Петровича заявление."
Компонента саморегистрирующаяся и поэтому должна заработать автоматически и молча, но если ей прав на регистрацию на вашем компе, все-таки, не хватит или политики безопасности местного сисадмина не дадут, пригоните его, ткните носом и пусть зарегит ее вручную.
Если вы совсем одни и помочь некому, пишите сюда или на почту kvest1c@ya.ru или в ФастХелп (в обработке кнопка) - я помогу. Это надо один раз сделать на всю жизнь.

Вот эта кнопка Help с листочком.
ТекРелиз="2019.05";
Добавлен реестр заявлений сотрудников о выборе ЭТК и БТК
Для работы с ним нужно переключится
В реестр можно добавлять сотрудников, подавших заявления и указывать их состояние и даты.

Просто тыкая по реестру.
Что-то перестало Заполнение работать из главной формы в ЗиК.
Что-то перестало Заполнение работать из главной формы.
Да. Спасибо.
Уже все исправлено.
- За сколько времени выучишь китайский язык?
- А когда сдавать?
© студ.анекдот
Но по-нашему, по-бухгалтерскому, это звучит так:
- Слышали про СЗВ-ТД?
- А когда сдавать?
У меня новая фишка, которой нет у рег.отчетов 1С, но теперь будет во всех моих.
Прямо в форме отчета видно когда ее надо сдать:
- если сегодня 01.02.2020, то это будет выглядеть так


А если бы сегодня было 17-е февраля, то вы бы увидели такое:

Ну, а после этого и вовсе:
Для этого надо было всего-то написать десяток строк кода, но почему-то никто до меня до этого не додумался.

Я - круче всех!
Тут ещё столкнулся с тем, что не все документы "кадровое перемещение" должны попадать в мероприятия СЗВ-ТД. Например, если работнику меняют только график работы или оклад. Их конечно можно просто удалять вручную из СЗВ-ТД, но предыдущие нужные мероприятия туда сами уже не попадут... Нужно чтобы отчётик брал только те "Кадровые перемещения", которые меняют должность и/или подразделение.
только те "Кадровые перемещения", которые меняют должность и/или подразделение.
Да.
Но есть проблема.
В ЗиК и Комплексной это легко проверить, а в Бух, УСН и ПБУ документ кадровое перемещение должность не меняет, только Подразделение и то всегда.
Это дело надо подумать.
Хотя бы в ЗиК сделайте.
ТекРелиз="2019.07";

По функционалу пока, наверное, все.
Больше пока ничего делать не буду, на 2020 год весь необходимый арсенал средств для формирования любых вариантов СЗВ-ТД есть.
Только подрихтовать неровности какие, если найдутся ...
Соответственно, появилось подробное текстовое описание по работе с отчетом. Пора. С картинками, как бухи наши любят ...
Позже запилю подробное видео, продолжение https://blogs.klerk.ru/users/1911762/post179394/ в котором для ленивых прочитаю по буквам встроенный мануал.
Удивительные вещи обнаружились при более внимательном изучении формата.
Что там ваши ЛСДУ3, ЙФЯУ9 и Российская Федерация в рос реестре! - детская игра в крысу.
Такие широкие возможности открываются для манипуляции с этими электронными трудовыми книжками, отечественные жулики будут очень рады.
Категорически никому не советую переходить ЭТК. Потом себя в своей же книге не узнаете ...
Мелкое замечание. Отчётный период - месяц должен быть 2х значным: январь - 01
ТекРелиз="2019.08";

По мотивам https://www.klerk.ru/buh/news/494952/#comment__774909
Реализован второй вариант.
Это какой второй? Второй раз не посылать состояние на 1.1.2020 ?
Кстати, печать заявлений логичнее было бы делать без выбора сотрудника. Ведь он уже выбран во вкладке заявлений.
Началось тестирование на реальных базах юзеров.
Хожу, читаю им лекции, провожу семинары, даю домашнее задание.
По результатам -
ТекРелиз="2019.09";
Ещё бы форму для работника СТД-Р запилить бы. Вдруг кому надо будет.
Нашёл баг. В списке заявлений удаляем сотрудника. Но после повторного открытия обработки он там снова появляется
А надо бы и список мероприятий за каждый месяц со всеми изменениями хранить. Потому как кадровики его редактировать будут вручную.
//******************************************************************************
Процедура ЗаписатьМеропрятия(ДатаПериода) //КК 6.2.20
Если СпМеропр.КоличествоСтрок()=0 Тогда
Возврат;
КонецЕсли;
ИмяФайла=КаталогИБ()+"czv_td"+ДатаПериода+".dbf";
ЗначениеВФайл(ИмяФайла,СпМеропр,1);

КонецПроцедуры // ЗаписатьМеропрятия

//********************************************************************************************
Процедура ЗагрузитьМероприятия(ДатаПериода) //КК 6.2.20
ИмяФайла=КаталогИБ()+"czv_td"+ДатаПериода+".dbf";
Если ФС.СуществуетФайл(ИмяФайла)=1 Тогда
ВремТабл=ЗначениеИзФайла(ИмяФайла);
СпМеропр.Загрузить(ВремТабл);
Иначе
СпМеропр.УдалитьСтроки();
КонецЕсли;
КонецПроцедуры
//********************************************************************************************
Процедура ИзменитьМесяц(Направление)
...
ЗаписатьМеропрятия(БылМесяц); //КК 6.2.20
ЗагрузитьМероприятия(ДатаПериода); //КК 6.2.20

КонецПроцедуры // ИзменитьМесяц()
//********************************************************************************************
Процедура ПриЗакрытии()
...
ЗаписатьМеропрятия(ДатаПериода); //КК 6.2.20
КонецПроцедуры // ПриЗакрытии
//********************************************************************************************
Процедура ПриОткрытии(Настр)
...
ЗагрузитьМероприятия(ДатаПериода); //КК 6.2.20
КонецПроцедуры // ПриОткрытии
Ещё в мероприятиях нет поля "сведения" который обязателен в некоторых случаях. Я увидел, что у вас используется "причина увольнения" для сведений. Но в п. 2.8. Правил заполнения написано, что сведения о переименовании должны быть в графе 4 печатной формы.
Страница 2 из 2
< 1 2
 

Подтвердите удаление записи