Дневник Кирилл1 Комментарии в дневнике
В дневнике Дневник Кошки Рyлят 11.02.2020 08:50
2. Это не рабочий код, а хлам. В топку ...
Там код, который содержит добавление в ваш отчёт. Сделан на основе вашего кода таблицы с заявлениями. И он рабочий. Все изменения сохраняются при переходе на другой период и при закрытии.
В дневнике Дневник Кошки Рyлят 10.02.2020 13:49
Узнавать это надо будет всем, кто сдаёт эту форму. Т.к. согласно пункту 1.7. Порядка заполнения, на кого не сдавали СЗВ-ТД в этом году, до 15.1.2021 г. нужно сдать. Поэтому информацию о сданных формах нужно хранить. Как это сделано в СЗВ-СТАЖ. Я уж не говорю про исправления при ошибках. Там вообще необходимо знать UUID ошибочного мероприятия. Код в соседней ветке я уже приводил https://blogs.klerk.ru/users/1911762...#commid1569717
В дневнике Дневник Кошки Рyлят 10.02.2020 13:08
И опять же не сохраняются введённые изменения. Как потом узнать, на кого передали данные, а на кого нет?
В дневнике Дневник Кошки Рyлят 10.02.2020 13:00
При переименовании предприятия в графе "Трудовая функция" указывается информация о переименовании (п.2.8. Правил Заполнения). У вас же эту информацию возможно ввести только в графу "Причины увольнения".
В дневнике Дневник Кошки Рyлят 06.02.2020 14:04
Ещё в мероприятиях нет поля "сведения" который обязателен в некоторых случаях. Я увидел, что у вас используется "причина увольнения" для сведений. Но в п. 2.8. Правил заполнения написано, что сведения о переименовании должны быть в графе 4 печатной формы.
В дневнике Дневник Кошки Рyлят 06.02.2020 11:22
А надо бы и список мероприятий за каждый месяц со всеми изменениями хранить. Потому как кадровики его редактировать будут вручную.
//******************************************************************************
Процедура ЗаписатьМеропрятия(ДатаПериода) //КК 6.2.20
Если СпМеропр.КоличествоСтрок()=0 Тогда
Возврат;
КонецЕсли;
ИмяФайла=КаталогИБ()+"czv_td"+ДатаПериода+".dbf";
ЗначениеВФайл(ИмяФайла,СпМеропр,1);

КонецПроцедуры // ЗаписатьМеропрятия

//********************************************************************************************
Процедура ЗагрузитьМероприятия(ДатаПериода) //КК 6.2.20
ИмяФайла=КаталогИБ()+"czv_td"+ДатаПериода+".dbf";
Если ФС.СуществуетФайл(ИмяФайла)=1 Тогда
ВремТабл=ЗначениеИзФайла(ИмяФайла);
СпМеропр.Загрузить(ВремТабл);
Иначе
СпМеропр.УдалитьСтроки();
КонецЕсли;
КонецПроцедуры
//********************************************************************************************
Процедура ИзменитьМесяц(Направление)
...
ЗаписатьМеропрятия(БылМесяц); //КК 6.2.20
ЗагрузитьМероприятия(ДатаПериода); //КК 6.2.20

КонецПроцедуры // ИзменитьМесяц()
//********************************************************************************************
Процедура ПриЗакрытии()
...
ЗаписатьМеропрятия(ДатаПериода); //КК 6.2.20
КонецПроцедуры // ПриЗакрытии
//********************************************************************************************
Процедура ПриОткрытии(Настр)
...
ЗагрузитьМероприятия(ДатаПериода); //КК 6.2.20
КонецПроцедуры // ПриОткрытии
В дневнике Дневник Кошки Рyлят 05.02.2020 10:57
Нашёл баг. В списке заявлений удаляем сотрудника. Но после повторного открытия обработки он там снова появляется
В дневнике Дневник Кошки Рyлят 05.02.2020 10:45
Ещё бы форму для работника СТД-Р запилить бы. Вдруг кому надо будет.
В дневнике Дневник Кошки Рyлят 03.02.2020 15:23
Кстати, печать заявлений логичнее было бы делать без выбора сотрудника. Ведь он уже выбран во вкладке заявлений.
В дневнике Дневник Кошки Рyлят 03.02.2020 09:30
Это какой второй? Второй раз не посылать состояние на 1.1.2020 ?
В дневнике Дневник Кошки Рyлят 02.02.2020 12:11
Мелкое замечание. Отчётный период - месяц должен быть 2х значным: январь - 01
В дневнике Дневник Кошки Рyлят 01.02.2020 18:29
Хотя бы в ЗиК сделайте.
В дневнике Дневник Кошки Рyлят 01.02.2020 10:43
Тут ещё столкнулся с тем, что не все документы "кадровое перемещение" должны попадать в мероприятия СЗВ-ТД. Например, если работнику меняют только график работы или оклад. Их конечно можно просто удалять вручную из СЗВ-ТД, но предыдущие нужные мероприятия туда сами уже не попадут... Нужно чтобы отчётик брал только те "Кадровые перемещения", которые меняют должность и/или подразделение.
В дневнике Дневник Кошки Рyлят 01.02.2020 10:40
опять новая версия?
В дневнике Дневник Кошки Рyлят 31.01.2020 14:37
Что-то перестало Заполнение работать из главной формы в ЗиК.
В дневнике Дневник Кошки Рyлят 30.01.2020 13:32
Эх, как сделали то ваши конкуренты... https://www.youtube.com/watch?v=GCuyYcHHOAY
В дневнике Дневник Кошки Рyлят 29.01.2020 22:44
А если у тебя за январь 2020 года больше сотни кадровых мероприятий, то иди к
Ты не понял. Текущие кадровые мероприятия - это малая толика из того, что предстоит сдавать работодателю в СЗВ-ТД. Кроме них ему предстоит в этом году сдать сведения на Всех работников по состоянию на 1.1.2020, и на Всех работников сдать сведения о заявлениях (которые у вас не реализованы вообще).
В дневнике Дневник Кошки Рyлят 29.01.2020 21:59
И ты правильно делаешь, что как истинный одинесник с большой буквы раз один 1, не читаешь мануалов и не смотришь видосов.
Ну зачем дерзить то сразу. Я смотрел видос. Вручную выискивать состояние на 1.1.2020 по каждому сотруднику это совсем не комильфо. А если их больше сотни? Всё равно до 15.02.2021 работодатели должны сдать эти сведения о всех работниках. И ещё сдавать сведения о заявлениях тоже на всех. При этом ещё вспоминать, на кого сдавали, а на кого нет... Кроме того надо ещё где-то хранить UUID, ведь его нужно указывать в случае отмены неверных сведений...
В дневнике Дневник Кошки Рyлят 29.01.2020 19:52
Автору респект. Но я вижу, что не реализовано предоставление сведений на 1.1.2020, если форма подаётся впервые, а так же нереализовано предоставление сведений о подаче заявлений 2х видов (о продолжении ведения в бумажном виде и о выдаче сведений сотруднику).
 

Подтвердите удаление записи